学生档案管理系统使用帮助

功能简介

学生档案管理系统提供学生管理（含奖惩处理）、成绩管理（含考试安排）、收费管理和住宿管理四大模块，以学生管理为基础，以成绩管理为特色，可轻松实现各类信息的单项录入和批量快速录入(CTRL+V粘贴和EXCEL导入)，提供丰富的查询、汇总功能、导出（EXCEL）和打印功能，从而实现学校规范、精细和高效的数字化管理。

数据库系统采用MS SQL，因此能保证大量的学生基本信息、奖惩信息、考试成绩、缴费信息等数据高效的储存与管理，数据库的约束功能和软件的数据校检功能减少了数据的出错率及不完整性。只要把数据库部署在局域网内的计算机或服务器上，在每科室的电脑上都安装上此软件，即可轻松实现多科室数据的处理与共享。

支持两个独立的数据库，比如可以把联合办学与在校生分开管理。

本软件主要适用于中等职业学校、高等职业学校等教育机构。

管理员用户名：ad　初始密码：123456

学生档案管理系统功能菜单简表

一级菜单 | 系统管理 | 成绩管理 | 学生管理 | 收费管理 | 住宿管理 | 公用信息 | 帮助
二级菜单 | 用户设置 部门设置 年级设置 收款员设置 公告设置 数据库备份 日志查看 退出系统 | 单人成绩处理 单科成绩录入 单科成绩汇总 学期成绩汇总 舞弊学生查询 成绩数据校验 学期补考通知 各科补考统计 补考成绩录入 补考成绩汇总 毕业补考通知 毕业补考统计 班级毕业成绩 个人毕业成绩 课程设置 学期设置 教师设置 考试安排 成绩导出ACCESS | 学生信息报表 单人信息处理 批量信息处理 学生异动处理 特殊学生查询 学生奖惩汇总 单人奖惩处理 专业设置 班级设置 班主任设置 城市设置 奖惩设置 | 班级交费汇总 单人交费处理 班级单项处理 拖欠费用查询 交费数据校验 收费项目设置 | 住宿办理 住宿查询 | 学生人数统计 学生名单报表 修改用户密码 信息汇报 信息查看 | 使用说明 注册产品 关于 学生档案管理系统


安装与注册

1、环境支持：

此软件是基于.net开发的，因此客户端只支持Windows系统，经测试WINXP和WIN7都能正常使用，需要安装.net framework 2.0及以上版本，分辨率不得低于1024*768。如果没有安装.net framework请到(http://msdn.microsoft.com/zh-cn/aa731542.aspx)下载。放置数据库的电脑或服务器应安装MS SQL2005，并打开远程访问功能（单机使用可不打开远程访问功能）。

2、安装：

点击setup.msi安装学生档案管理系统。

安装完毕，在放置数据库的电脑或服务器上安装MS SQL2005，并打开远程访问功能（单机使用可不打开远程访问功能）。方法如下：首先打开官方网站http://msdn.microsoft.com/zh-cn/express/bb410792.aspx下载Microsoft SQL Server 2005 Express Edition和SQL Server Management Studio Express，参照安装目录下的“SQLExpress2005安装方法.doc”进行MS SQL2005的安装；打开数据库远程访问功能的方法请参阅http://support.microsoft.com/kb/914277/。用安装目录下的“backup”文件夹中的数据库备份文件student.bak创建两个数据库，如仅用一个数据库可创建一个。

3、注册：

初次打开本软件会出现注册页面，把机器码(需要发送多台电脑的机器码除非您单机使用)、贵单位的名称发送到E-Mail:mednur@163.com，电话联系：13639661893(王占欣)，然后我把注册码列表和单位码发送给贵单位。注册时还需要您正确填写两个数据库的连接字符串(引号内内容，仅使用一个数据库可只填写数据库一连接字符串)，：

①数据库一连接字符串：“Data Source=192.168.0.8;Initial Catalog=student;User ID=sa;Password=******;”或“Data Source=.\SQLEXPRESS;Initial Catalog=student;User ID=sa;Password=******;”

②数据库二连接字符串：“Data Source=192.168.0.8;Initial Catalog=student2;User ID=sa;Password=******;”或“Data Source=.\SQLEXPRESS;Initial Catalog=student2;User ID=sa;Password=******;”

数据库在局域网Data Source应填写IP如“192.168.0.8”，数据库在本机Data Source应填写实例名称如“.\SQLEXPRESS”等，Initial Catalog为数据库名如student，******为sa用户登录数据库的密码，如果用户名不是sa,其服务器角色应选中sysadmin，这样管理员才能进行数据库备份。

如果数据库连接字符串填写错误会使系统无法登录，此时请先删除系统安装目录下的注册文件key.txt，再运行程序进行注册。

如果要试用的话，请正确填写数据库的连接字符串，点击“注册为试用版”。试用版有部分功能限制，如：无法进行年级设置，部分报表信息不能导出EXCEL、不能打印等。


系统管理

1、用户设置

添加：用户名和密码为必填项，注意权限设置，共分为六个权限组，每个权限组又分为只读和读写两种权限。系统管理员：可以进行所有操作，权限最大；教务信息管理员：可以进行成绩管理；学生信息管理员：可以进行学生管理；财务信息管理员：可以进行收费管理；住宿信息管理员：可以进行住宿管理；一般用户：可查看公用信息也可进行信息汇报和查看帮助，权限最小，只读权限和读写权限的一般用户能进行的操作是相同的，可以提交信息汇报。一般用户权限外的用户也同时享有一般用户权限。

修改：不能直接修改用户名，如要修改，请通过先删除再添加来完成。选中密码前的复选框也可进行密码的修改。

删除：选中要删除的用户名，点击“确定删除”按键即可。系统管理员不能被删除。

2、部门设置：部门如教务科或教务处、学生科或学生处、财务科或财务处等可根据贵单位的实际情况进行修改。

3、年级设置：此处的年级是以入学年份定义的年级，并非一年级二年级的意思。编号大小是排序的依据，如下图只有“2008级”的编号小于“2009级”时“2008级”才会排在“2009级”的前面。学生毕业后，应把该年级“可用状态”列修改为非选中状态。“学生信息编辑状态”列为非选中状态表示该年级的学生基本信息被锁定不能修改。删除时注意选中年级名称。

4、收款员设置：基本操作同年级设置。

5、公告设置：任何权限的用户登录系统后，都可以第一时间看到最近一次的系统公告，此公告可以是紧急通知当然也可以其他说明，方便统一管理。

公告添加：输入标题和内容点击提交即可，点击重置可以清空标题和内容。

公告修改删除：在左侧的发布时间列表中选中后，相应公告可显示在右侧的公告信息栏内，“保存”按钮完成修改，“删除”按钮完成删除。

6、备份数据库：数据库备份是管理员的重要工作，定期备份可以有效减少误操作或其它意外引起的损失。因此管理员必须进行规律的定期备份。数据库连接字符串中的用户应具有sysadmin的服务器角色，才能进行备份。

7、日志查看：可以查看每次登录时登录者的用户名、权限、IP、计算机硬件信息、操作系统及时间等。


学生管理：

此部分提供学生的基本信息管理和学生奖惩处理两项功能。学生基本信息管理是其它信息管理的基础，没有学生基本信息，就无法进行成绩管理、收费管理及住宿管理等。

1、相关设置

专业设置、班级设置、班主任设置、奖惩设置：同系统设置中的收款员设置。

城市设置：编号共7位，前4位为省代码，中间2位为地级市代码，最后3位为县代码。技巧：根据学生的分布城市特点对编号做适当调整，如大部分学生在河南许昌，那么河南许昌的代码应是最小的。

2、信息处理

学号是学生的唯一标识，因此每个学生的学号不能重复。特别注意： ① 学生退学后其学号不能给他人使用；② 不能直接把张三的信息修改成李四的信息，即使张三已退学或开除也不行，因为张三可能已有奖惩、收费和成绩信息。

2.1　学生信息报表：

2.2　单人信息处理：单人信息添加、单人信息修改

身份证号决定了出生日期和性别，如果性别和身份证号不相符，则在进行添加和保存修改时性别会自动更改。

2.3　批量信息处理：批量信息添加、批量信息修改

批量信息添加：点添加后数据交只是添加到了下面的方框里，只有保存成功后才真正完成了添加。选中“CTRL+V批量录入”时，可以通过CTRL+V把内存中的内容粘贴到下面方框的相应位置，可实现快速录入。还可以通过导入EXCEL功能进行快速而准确的学生信息录入。

EXCEL学生信息导入：请参阅安装目录下的“学生信息导入样例.xls”。

批量信息修改：选中“CTRL+V批量录入”时，可以通过CTRL+V把内存中的内容粘贴到下面方框的相应位置，从而实现快速修改。

2.4　学生异动处理：是单人信息修改的简化形式，这里可以进行转班、转专业、退学、开除、处分等的处理，在何时进行的何项内容的修改需要在备注里面注明。

如果贵单位只需要简单的“学生信息管理”，可以通过批量信息处理添加和修改学生名单，然后的转专业、退学等信息的处理在此处进行。

2.5　特殊学生查询：查找退学、开除、休学或备注内容非空的学生信息。

2.6　学生奖惩汇总

学生量化考核的成绩按从高到低的顺序排列，100分说明该生既无奖励也无处罚。选中“班级”前面的方框时，只显示当前年级当前班级的学生量化考核成绩汇总，非选中时，显示当前年级所有学生的量化考核成绩汇总。

打印时可以选择是否添加备注信息。效果图如下：

2.7　单人奖惩处理

学生量化考核是学生管理工作的重要一环。进行此项操作前，应先进行“奖惩项目设置”添加需要的项目如旷课、好人好事等。通过组合条件查询，然后单击“查询结果列表”中的某一行，即可显示该学生的所有奖惩信息，再根据需要进行添加、修改、删除等操作，也可以打印该生的奖惩信息汇总表。

注意：奖励成绩记为正值，处罚成绩记为负值。


成绩管理

成绩管理是本软件的最主要功能，经过三年多的试用和改进，基本满足了中高职院校的成绩处理。成绩管理的前提是学生基本信息的已录入。

功能涵盖成绩的单项和批量录入、EXCEL导入、查询与修改，还提供了强大的导出(EXCEL)和打印汇总报表功能，可自动生成班级学期成绩汇总表、班级毕业成绩汇总表、学生毕业成绩档案表（单表）、学生成绩录入名单、考生座次表和考场记录表等。

1、相关设置

1.1 学期设置：编号为五位数字，不能重复，最新的学期编号应当设为最小。当前学期的选中状态主要与毕业补考通知单的打印效果有关(详见毕业补考通知)。

1.2 教师设置：操作方法同系统设置的收款员设置。应注意退休的要及时更改在职状态。

1.3 课程设置：此项设置是成绩处理的前提，它规定了某年级某专业某学期要考试的课程及课程类型等信息。课程类型分为考试课、考查课和技能课，考试课和考查课以具体的成绩计分，技能课输出的是不合格(<60)、合格(60-80)、优秀(>=80)。可进行添加、保存修改、单行删除、全部删除和打印(已录入的某年级某专业的全部考试课程)。

2、首考成绩处理

2.1 单人成绩处理：单人成绩的查询、添加、修改、删除。

通过查询条件生成查询结果列表，点击查询结果列表中某学生的学号，该学生的所有成绩信息就显示在下方的学生成绩栏内。可以在学生成绩栏内直接修改成绩和补考成绩，课程修改需要通过按钮课程修改完成。

2.2 单科成绩录入：此功能可很好完成学生成绩的批量录入，不用一个一个的手动录入，而是把任课教师交到教务科单科成绩表粘贴(CTRL+V)到此处的表格中或者直接导入外部EXCEL数据。选择好年级专业班级学期和课程后点击批量添加添加该班级的成绩，但此时的成绩均为空，再把任课教师交的EXCEL成绩表的成绩列复制(CTRL+C)后再粘贴(CTRL+V)到此处的表格中，注意粘贴前应先选中此表格第一行的成绩列中。保存修改后才能真正完成成绩的录入。另外课程编号也可以通过复制粘贴的方法完成批量修改。如发现添加错误，可通过删除全部删除表格内的成绩。

EXCEL导入功能由于提供了多重数据验证进一步减少了成绩录入错误的可能。导入前请参阅安装目录下的“成绩导入样例.xls”。

2.3 单科成绩汇总：导出(EXCEL)或打印某年级某专业的某课程的成绩汇总表，也可以导出(EXCEL)或打印某年级某专业的某个班级的某课程成绩汇总表。

2.4 学期成绩汇总：导出(EXCEL)或打印某年级某专业某班级(或所有班级)某学期(或所有学期)所有课程的成绩汇总表，最后一列为总成绩，并且按分数由高到低的顺序排列。

打印时可进行纸张大小方向及页边距的设置。

打印效果如下图。

2.5 舞弊学生查询：

2.6 成绩数据校验：由于转专业、补录学生、休学、留级等原因会造成相应成绩记录的异常或缺少，注意缺考考生也应该添加该课程的成绩为空的成绩记录。否则在补考通知单及毕业成绩档案表中不会列出。双击可以弹出添加或修改形成对话框。

3、补考成绩处理

3.1 学期补考通知：生成某年级某专业某班级某学期的补考通知单，可以直接打印也可以导出EXCEL。√代表不及格，○代表缺考，△代表作弊。

3.2 各科补考统计：从统计表中可以看到每门课程各班的补考人数及总计人数，可以轻松确定补考试卷的印刷量及进行补考考场安排等。

3.3 补考成绩录入：录入某课程的补考成绩。

3.4 补考成绩汇总：导出(EXCEL)或打印某年级某专业的某学期所有补考课程的补考成绩汇总表，也可以导出(EXCEL)或打印某年级某专业的某个班级的某学期所有补考课程的补考成绩汇总表。

4、毕业成绩处理

4.1 毕业补考通知：经补考仍未通过考试的考生名单课程汇总，这些学生需要在毕业前进行最后一次补考。√代表不及格，○代表缺考，△代表作弊。有的显示两个标记（前一个为首考情况，后一个为补考情况），有的显示一个标记(实习前的最后一个学期的补考没有进行，因此和毕业补考同时进行是合适的)。在学期设置中把某一学期设为“当前学期”，该学期的课程才会显示为一个标记。课程名称后面的括号内的数字代表第几个学期。

4.2 毕业补考统计：可以统计出某专业、某班级、某课程的补考人数，以此来安排学生补考，最后一行为总计。可以根据此统计表确定补考试卷的印刷数量和安排补考。

4.3 班级毕业成绩：学生毕业成绩要存档，每个班级都有一个在校期间学习的所有课程的成绩汇总表，可打印(大幅面打印机是必要的)也可导出EXCEL。课程名称后括号内的数字代表第几学期。

打印效果图：

4.4 个人毕业成绩：学生档案里必不可少的学生成绩档案表。显示学生的基本情况、每学期的课程及课程类型和考试及补考成绩，能生成EXCEL，还可以根据生成的EXCEL进行适当修改并打印。单人成绩单是导出查询结果中被选中的学生的成绩单，多人成绩单是导出查询结果中所有学生的成绩单。

生成的学生成绩EXCEL表格样图。

5、考试安排

可以自动生动成绩录入名单成、考生座次表和考场记录表的EXCEL文件。

6、成绩导出ACCESS

为了实现INTERNET上学生成绩的在线查询，可以把符合条件的成绩记录导出到ACCESS文件中。如果导出成绩记录条件为空，将导出可用年级的所有学生的成绩记录。


收费管理

1、相关设置

收费项目设置：规定了某年级某专业某收费项目的收费标准。

2、收费信息处理

班级交费汇总：最后一列为每生所交费用的总数(合计)，最后一行显示单项费用总计。

单人交费处理

可对某学生的交费信息进行查询、添加、修改、删除。

班级单项处理

以班级为单位进行添加修改删除，可以实现快速录入。

拖欠费用查询

双击某行可以弹出添加该学生交费信息对话框。

交费数据校验：

可列出某年级显示异常的交费信息，这些信息产生的原因主要是学生留级或转专业，这些交费信息如不修改其不会显示在“班级交费汇总”。


住宿管理

住宿办理：注意宿舍床位号的格式。

住宿查询：提供两种方式的查询，一是通过宿舍号查找学生，一是能过学生基本信息查找学生所在宿舍号。


公用信息

学生人数统计：从表中可以轻松得知每专业每班级的人数及每专业的总计人数等。

学生信息报表：可以生成各班级的学生名单，如下图把列标题设为“成绩”可生成教师录入成绩的学生名单(EXCEL)，教师录入的成绩，可以通过CTRL+V进行快速的单科成绩录入。

修改密码：输入旧密码和新密码完成当前登录用户的密码修改。

信息汇报：任何登录用户都可以提交信息汇报。

信息查看：查看提交的信息汇报，只能由具有写权限的系统管理员和相应权限分组管理员查看。


常见问题

1、系统登录时管理员用户名和初始密码是什么？

答：管理员用户名：ad 初始密码：123456

2、试用版都有哪些功能限制？

答:试用版不能进行“年级设置”，部分汇总报表不能导出EXCEL表也不能打印。

3、程序已安装并注册，初次使用应先后进行哪些设置？

答：①系统管理：用户设置、部门设置

②系统管理：年级设置→学生管理：专业设置、班级设置、班主任设置、城市设置→录入学生基本信息→查找修改汇总导出打印

③成绩管理：学期设置、课程设置→录入成绩信息→查找修改汇总导出打印

④学生管理：奖惩设置→录入学生奖惩信息→查找修改汇总导出打印

⑤系统管理：收款员设置→收费管理：收费项目设置→录入学生各项交费信息→查找修改汇总导出打印

4、学号录入错误，能否修改？

答：能修改，但不允许把学生甲的基本信息直接修改为学生乙的基本信息。

5、打开“单科成绩录入”，除了年级其余项都不显示，无法进行成绩录入？

答：成绩录入前必须先进行“课程设置”，录入某年级某专业某学期的考试课程及相关信息。

6、下图中年级组合框下拉列表中的项目显示顺序怎么调整？下图中的小方框有什么作用？

答：菜单“系统管理”－“年级设置”中的年级编号顺序决定了组合框下拉列表中项目的显示顺序，因此适当调整“年级设置”中的年级编号顺序可以得到我们想要的显示效果。同理，班级、专业、学期等组合框下拉列表中的项目显示顺序也可以根据需要进行调整。选中小方框相当于执行小方框后的约束条件，如上图选中学期前的小方框是指仅显示“2010～2011学年第2学期”的汇总结果，选中备注信息前的小方框是指打印补考通知单时显示备注信息。

7、登录系统时显示“数据库打开错误！”，怎么办？

答：有以下几种情况：1、数据库的远程访问功能没有打开，请打开MS SQL的远程访问功能；2、系统的注册文件key.txt破坏，请删除后再进行注册，注册时请填写正确的数据库连接字符串；3、数据库不存在，请创建相应数据库。

8、屏幕分辨率对本软件的使用有没有影响？

答：要求屏幕分辨率在1024*768以上，分辨率过低会造成系统的不正常显示。


关于购买

如果您有意购买此软件的话，可先试用再付款。可以通过支付宝进行汇款。

价格根据您要求的服务而不同。

联系电话：13639661893(王占欣)

QQ：8458755(注明学生档案管理系统)

E-Mail:mednur@163.com


作者简介

我叫王占欣，医学院校毕业，计算机是我的最爱，在河南省许昌市从事医学教育工作，并担任着学校几千人的考务及成绩管理工作。

因为工作的需要开发了学生档案管理系统(成绩管理模块最完善功能最强大)，在三年多的试用中不断改进完善，目前已升级至4.0版本。

我还可以开发一些小软件，如果贵单位有要求，可以为您量身定做。

个人网站：病理学园地(http://www.binglixue.com) 医护学习网(http://www.mednur.com)

E-Mail:mednur@163.com

QQ:8458755(请注明学生档案管理系统)


敬告用户

尽管作者对软件进行了反复的测试，但由于精力和能力有限，所以难免会出现问题。使用过程中如出现程序错误或结果与您计算的不相符，请通过Email等方式告知作者，作者将万分感谢！

由于使用本软件造成的损失，作者不承担任何责任，请贵单位规范管理，管理员及时备份数据库，在管理员认真阅读帮助文档的基础上做好操作员的培训工作。

如果您是经作者授权的正版用户，在服务期限内作者可提供技术服务。